Se ha producido un error que impide que algunas personas utilicen Google Wallet

Published:

TL;RD

  • Algunas personas informan que no pueden usar Google Wallet.
  • La causa raíz del problema es un error que afirma que el dispositivo está rooteado o que está usando un software no certificado.
  • El software en cuestión podría ser el sistema de seguridad propietario de Google.

Si tiene problemas para usar Google Wallet, no está solo. Varias personas informan que experimentan un error que les impide usar la aplicación.

como fue descubierto por policía androide, algunos usuarios de Google Wallet en Reddit informan que no pueden usar Google Wallet. Estos usuarios parecen estar encontrando un problema de seguridad que provoca una notificación de que su dispositivo está rooteado o está usando software no certificado.

A pesar de usar teléfonos Google Pixel y Samsung Galaxy sin modificar, el aviso aparece cada vez que intentan usar Google Wallet. Incluso las soluciones rápidas, como borrar el caché de Play Store, no parecen funcionar.

Como policía androide estados, el problema podría estar relacionado con la API de certificación de SafetyNet, algo que Google usa para asegurar los pagos cuando usa Google Wallet.

Al usar Google Wallet, la API de atestación de SafetyNet realiza una verificación en el dispositivo para asegurarse de que no se haya visto comprometido de una manera que haga que el envío de información confidencial sea riesgoso. Esto significa asegurarse de que el cargador de arranque, el programa que le dice a su teléfono qué sistema operativo ejecutar, esté bloqueado. Si su teléfono pasa la verificación, puede realizar un pago con Google Wallet.

Sin embargo, Google planea reemplazar la API de certificación de SafetyNet con una nueva API llamada Play Integrity para 2024. Si bien 2024 es la fecha límite para que las aplicaciones de terceros comiencen a usar Play Integrity, es posible que Google ya haya comenzado a implementar la API en parte de su propio software. De acuerdo a Mishal RahmanEditor técnico de Esper, Google Wallet ya se ejecuta en Play Integrity.

Si la verificación de certificación de SafetyNet detecta la API de Play Integrity, SafetyNet puede estar considerando un software no certificado de Play Integrity. Esto haría que la aplicación quedara inutilizable.

En este punto, no está claro qué causa exactamente el error, pero esta explicación parece plausible. Tendremos que esperar a que Google responda.

Esto te podría gustar..

Recién publicado